Sie sind vermutlich noch nicht im Forum angemeldet - Klicken Sie hier um sich kostenlos anzumelden Impressum 
Sie können sich hier anmelden
Dieses Thema hat 18 Antworten
und wurde 966 mal aufgerufen
  
 Equipment & Patches
Scipio Offline

Literaturmajor


Beiträge: 1.812

08.01.2007 00:54
Einheitentyp wird nicht angezeigt Antworten
Hi,
ich habe folgendes Problem mit dem neuen RSF:

die Einheitentypen werden in PG nicht angezeigt, und wenn ich mit rechts auf die Einheit klicke, stürzt PG ab.
Die Grafiken scheinen OK zu sein.

Frage: in welchem Bereich ist der Fehler zu suchen?

Ausgang: Basis SSI-PG-Installation
Danach:
1. UK-Patch + enthaltene ZIPs in entsprechende Verzeichnisse kopiert
2. RSF 2.4 installiert (wird auch auf dem Startbildschirm angezeigt
3. Panzer.dat installiert
4. Sounds installiert

Gruß
Scipio

Rayydar Offline

Generalspammarschall


Beiträge: 11.838

08.01.2007 03:33
Einheitentyp wird nicht angezeigt Antworten
Sag bloß, du hattest keine RSF 2.05-Installation?
Was ist mit den DLLs???

Scipio Offline

Literaturmajor


Beiträge: 1.812

08.01.2007 12:51
Einheitentyp wird nicht angezeigt Antworten
Hi Rayy,
Du kannst die Betablocker absetzen: selbstverständlich hatte ich eine RSF 2.05-Installation. Jetzt läuft's auch mit dem 2.4...

Die alte Installation zu kopieren und dann zu überschreiben - warum bin ich nicht selbst auf die Idee gekommen? Ich verneige mit in Ehrfurcht vor dem Genie des wahren Cayysars.
Gruß
Scipio

Rayydar Offline

Generalspammarschall


Beiträge: 11.838

08.01.2007 14:52
Einheitentyp wird nicht angezeigt Antworten

Quote:
Die alte Installation zu kopieren und dann zu überschreiben - warum bin ich nicht selbst auf die Idee gekommen? Ich verneige mit in Ehrfurcht vor dem Genie des wahren Cayysars.

Letzteres ist adäquat.
Aber warum nicht einfach die drei 2.40-Files in die bestehende 2.05-Installation einfügen?

NisRanders Offline

Postingschütze

Beiträge: 144

08.01.2007 19:23
Einheitentyp wird nicht angezeigt Antworten

Quote:

Quote:
Die alte Installation zu kopieren und dann zu überschreiben - warum bin ich nicht selbst auf die Idee gekommen? Ich verneige mit in Ehrfurcht vor dem Genie des wahren Cayysars.

Letzteres ist adäquat.
Aber warum nicht einfach die drei 2.40-Files in die bestehende 2.05-Installation einfügen?


Das hatte bei mir einen Absturz zu Folge. Ich musste es komplett neu installieren. PG IIID ist einfach schlampig programmiert.

Rayydar Offline

Generalspammarschall


Beiträge: 11.838

08.01.2007 23:15
Einheitentyp wird nicht angezeigt Antworten
Grundsätzlich ist nicht nur PG3 grottig programmiert, sondern auch das Zusammenspiel mit Windows lässt zu wünschen übrig.

Bei allen Problemen sollte man zuerst mal versuchen, die Registry aufzuräumen. Das hat schon einigen geholfen. Geeignete Tools gibt es im Netz. Da aber manche Freeware-Tools auch mal was zerschießen, sollte das benutzte wenigstens eine Backup-Funktion haben - und die sollte man auch verwenden!

Scipio Offline

Literaturmajor


Beiträge: 1.812

09.01.2007 00:36
Einheitentyp wird nicht angezeigt Antworten
Hi Rayy,
auch wenn Du als Microsoft-Jünger das natürlich anders siehst: aber der Erfinder der Registry sollte täglich geprügelt werden.

Groß, unübersichtlich, fehleranfällig und im Prinzip auch total überflüssig. M.a.W. typischer MS-§@!§&.

Aber textbasierte Konfigurationsdateien wären ja auch echt zu einfach gewesen...

Gruß
Scipio

Rayydar Offline

Generalspammarschall


Beiträge: 11.838

09.01.2007 02:17
Einheitentyp wird nicht angezeigt Antworten
Sooo anders sehe ich das gar nicht.
Allerdings:
1. Ist in der Registry wenigstens eine hierarchische Ordnung, auch wenn ich sie nicht verstehe. Textdateien wären da wohl nicht die Alternative.
2. Kann Microschuft nix dafür, wenn Fremdprogramme wie die größte Bananensoftware aller Zeiten aka PG3 sich nicht sauber (de-)installieren.

Scipio Offline

Literaturmajor


Beiträge: 1.812

09.01.2007 09:35
Einheitentyp wird nicht angezeigt Antworten
Hi,
meiner Meinung nach ist schon der Ansatz, ALLES zentral zu verwalten miserabel.
Warum müssen die estzeiten von Minesweeper unter WinXP in der Registry stehen? Warum muß Programm A die Einstellungen von Program B zentral auslesen? Tut es nicht auch eine Config-Datei im Verzeichnis von Programm B?
Dann gibt es nämlich auch keine Probleme mit der Deinstallation.

OS-eigene Einstellungen können ja von mir aus zentral gespeichert werden (wobei ich selbst hier Textdateien bevorzugen würde), aber Programme sollen ihre Config-Dateien bitteschön selber schreiben.

Und nun:

Bzgl 1:
Ich sage nur XML: hierarchisch und Textdatei. Das gab es zwar meines Wissens nach Mitte der 90er noch nicht, aber inzwischen könnte MS ruhig mal umsatteln. Oder sind in der Registry auch Binärobjekte gespeichert?

Bzgl 2:
Stimmt.

Gruß
Scipio

Rommel Offline

Stabsschreiber


Beiträge: 790

11.01.2007 23:26
Einheitentyp wird nicht angezeigt Antworten
übrigens hab ich das gleiche problem wie oben beschrieben mit dem neuen RSF, es werden keine einheitentypen angezeigt und beim rechtsklick auf eine einheit stürzt das spiel ab.
ich habe natürlich, auch aus faulheit, die bestehende rsf 2.05-installation einfach kopiert und dann die rsf 2.4-dateien ins hauptverzeichnis reinkopiert.

ich hab seit 2 monaten einen neuen pc mit windows xp, das rsf 2.05 lief aber bisher ganz normal.

was kann ich tun ?

Rayydar Offline

Generalspammarschall


Beiträge: 11.838

11.01.2007 23:57
Einheitentyp wird nicht angezeigt Antworten
Ach Leut ... *seufz*:
Entweder das 2.40 in die funktionierende 2.05-Installation packen (obwohl bei Scipio nicht mal das klappte) und die Kopie restlos löschen.
Oder neu installieren - wobei das logischerweise wg. der Registry erst recht Probleme geben müsste. Aber was ist daran schon logisch?

Und wieso habe ich eigentlich diese Probleme nie?
Weil ich das 'entweder' (s.o.) gemacht habe.
Der Wechsel von 2.05 auf 2.40 besteht doch nun wirklich nur aus dem Tausch von drei Mini-Files ...

Scipio Offline

Literaturmajor


Beiträge: 1.812

12.01.2007 00:51
Einheitentyp wird nicht angezeigt Antworten
Hi Rayy,
fast allwissend ist noch nicht ganz allwissend. Wie kommst Du darauf, daß die Reinkopieren in die funktionierende RSF2-Installation nicht funktioniert hätte?

Die Probleme hatte ich mit dem SSI-EQF als Basis, mit dem RSF 2 funktionierte alles wunderbar.

Gruß
Scipio

Rayydar Offline

Generalspammarschall


Beiträge: 11.838

12.01.2007 14:03
Einheitentyp wird nicht angezeigt Antworten

Quote:
Wie kommst Du darauf, daß die Reinkopieren in die funktionierende RSF2-Installation nicht funktioniert hätte?
Die Probleme hatte ich mit dem SSI-EQF als Basis, mit dem RSF 2 funktionierte alles wunderbar.

Sorry, dann hatte ich das falsch verstanden. Umso besser! Also 'Tagesbefehl': Die RSF 2.4-Files einfach in die funktionierende 2.05-Installation klatschen, und Ruhe ist! Es gibt auch wirklich keinen plausiblen Grund, warum das nicht funktionieren sollte.

Winter Offline

Stabsschreiber


Beiträge: 801

12.01.2007 15:17
Einheitentyp wird nicht angezeigt Antworten
hat bei meiner WINNT Partition auch ohne Probleme gefunzt... leider auf dem Laptop / XP immer noch fehlanzeige... aber ich bleibe hartnäckig... bis zur letzten Diskette!

Was mich allerdings wundert... installiere ich die 2.40 "nackt" pber haben die soviets als anführericon ein weißer stern in schwarzem kreis... bei "überbraten" des 2.05 mit dem 2.40 bleibt der rote stern (viel schöner) erhalten... rätzel über rätzel...

Rayydar Offline

Generalspammarschall


Beiträge: 11.838

12.01.2007 20:01
Einheitentyp wird nicht angezeigt Antworten

Quote:
installiere ich die 2.40 "nackt" pber haben die soviets als anführericon ein weißer stern in schwarzem kreis

Wenn du 2.4 'nackt' installierst, musst du natürlich auch alles installieren, d.h. auch die panzer2.dat und den SFX-Ordner.

Rommel Offline

Stabsschreiber


Beiträge: 790

03.02.2007 13:43
Einheitentyp wird nicht angezeigt Antworten
übrigens habe ich gerade heute das geheimnis meiner nicht angezeigten einheitentypen und des absturzes nach rechtsklick auf die einheiten entzaubert...
ich sage nur, der wahnsinn steckt im detail !!! uff, aus sowas muß man erstmal kommen.

mein ursprünglicher PG-ordner für RSF 2.05 hieß "PanzerGeneral 3D - RSF 2" und dort klappte es ohne probleme. für das RSF 2.40 hab ich den kopiert, die dateien aktualisiert und in "PanzerGeneral 3D - RSF 2.40" umbenannt und dort ging nix mehr. hab es heute nochmal getestet und die "PanzerGeneral 3D - RSF 2" kopiert und die dateien der RSF 2.40 in den ursprünglichen ordner eingefügt. dort funzte es plötzlich!
als ich den ordner dann in "PanzerGeneral 3D - RSF 2.40" umbenannte gings wieder nicht mehr!!!
die ältere version von "PanzerGeneral 3D - RSF 2" in "PanzerGeneral 3D - RSF 2.05" geändert geht nicht, aber bei "PanzerGeneral 3D - RSF 2-05" läuft... verstehe einer diese logik!!!
aber nun bin ich glücklich, daß es funktioniert und ich wieder voll aktiv werden kann.
Rayydar Offline

Generalspammarschall


Beiträge: 11.838

03.02.2007 14:18
Einheitentyp wird nicht angezeigt Antworten
PG akzeptiert also keine Punkte im Ordnernamen - wirklich faszinierend, denn das ist gültige Windows-Syntax.
Wieder ein Mysterium gelöst!

Galland Offline

Verbalkanonier


Beiträge: 589

04.02.2007 19:49
Einheitentyp wird nicht angezeigt Antworten
Das mit den Punkten zur Versionsdarstellung musste ich mir auch abschminken.
Hatte das prob aber schon vor einiger Zeit, hab nur vergessen zu posten
Infernalex Offline

Forumsgrenadier

Beiträge: 327

06.07.2007 11:58
Einheitentyp wird nicht angezeigt Antworten
Hallo Rommel,

hatte grade das selbe Problem wie du und bin froh daß ich diesen Thread und deine geniale Lösung gefunden habe:-)))
Ähnliche Themen Antworten/Neu Letzter Beitrag⁄Zugriffe
Problem das PG die Karten lädt und überhaupt läuft!
Erstellt im Forum Equipment & Patches von Eule
2 21.09.2009 23:58
von Eule • Zugriffe: 702
Klotzen Kampagne -> läuft nicht
Erstellt im Forum Kampagnen von
8 11.01.2005 20:48
von nobody • Zugriffe: 1032
bin wieder da und hab direkt fragen...
Erstellt im Forum Sonstige PG3D-Themen von
10 04.11.2004 16:53
von nobody • Zugriffe: 691
PG 3D läuft bei mir nicht. Bitte helfen!
Erstellt im Forum Equipment & Patches von MrKaese
8 13.01.2006 09:56
von nobody • Zugriffe: 1133
Problem bei Klotzen
Erstellt im Forum Kampagnen von hope
7 17.06.2006 12:09
von nobody • Zugriffe: 960
Kann meine Kerneinheiten nicht aufrüsten!
Erstellt im Forum Kampagnen von Joe
7 10.09.2007 14:33
von nobody • Zugriffe: 816
Maps werden nicht angezeigt
Erstellt im Forum Sonstige PG3D-Themen von Jo
12 11.01.2008 11:47
von nobody • Zugriffe: 772
Falsche Einheitenstärke wird angezeigt
Erstellt im Forum Kampagnen von Panzerlurch
5 23.08.2008 00:09
von nobody • Zugriffe: 645
RSF Szenario wird nicht angezeigt
Erstellt im Forum Equipment & Patches von Major Heinz
3 23.02.2009 07:26
von nobody • Zugriffe: 676
 Sprung  

  PBEM-Liga für PG3D und viele weitere Spiele: »Panzerliga.de« *** Internationales OG-Forum: »Open General Forums« (engl.)  

Xobor Ein Kostenloses Forum von Xobor.de
Einfach ein Forum erstellen
Datenschutz